11

Commercial Finite Element Program ABAQUS Tutorials

by ABAQUS, Inc.

11.1 INTRODUCTION

In this series of tutorials you will become familiar with the process of creating ABAQUS models interactively using ABAQUS/CAE. Three problems will be considered: (1) steady-state heat conduction in a trapezoidal plate, (2) bending of a short cantilever beam and (3) the elasticity problem of a plate with a hole subjected to uniform far-field tension.

11.1.1 Steady-State Heat Flow Example

You will create a model of the plate as shown in Figure 11.1. The system of units is not specified but all units are assumed to be consistent. The plate is of unit thickness and subjected to the conditions shown in the figure. You will perform a series of simulations with increasing levels of mesh refinement using both linear triangular and linear quadrilateral elements.

11.2 PRELIMINARIES

1. Start a new session of ABAQUS/CAE by entering abaqus cae at the prompt. Note that abaqus should be replaced with the command on your system used to run ABAQUS. For example, to run the ABAQUS v6.6 Student Edition, the command is abq662se.

2. Select Create Model Database from the Start Session dialog box. The Model Tree is located to the left of the toolbox area of the ABAQUS/CAE window. If the Model Tree is not visible, make sure that there is a check mark next to Show Model Tree in the View menu. If the Model Tree is still not visible, drag the cursor from the left side of the ABAQUS/CAE window to expand the Model Tree.

The Model Tree provides a visual description of the hierarchy of items in the model database along with access to most of the functionality available in ABAQUS/CAE. If you click the mouse button 3 (MB3) on an item in the tree, a menu appears listing the commands associated with the item. For example, Figure 11.2 shows the menu for the Models container. In the Models menu, the Create menu
item appears in bold because it is the default action that will be performed when you double-click the Models container.

3. Before proceeding, rename the current model. In the Model Tree, click MB3 on the model named Model-1 and select Rename from the menu that appears. Enter heat in the Rename Model dialog box and click OK.

4. To save the model database, select File → Save As from the main menu bar and enter the name abq-tutorials in the File Name line of the Save Model Database As dialog box. Click OK.

The .cae extension is added automatically.

11.3 CREATING A PART

The first step in modeling this problem involves sketching the geometry for a two-dimensional, planar, deformable solid body.

1. In the Model Tree, double-click Parts to create a new part.

The Create Part dialog box appears.
2. Name the part **plate**. In the **Create Part** dialog box, select **2D Planar** as the part’s modeling space, **Deformable** as the type, and **Shell** as the base feature. In the **Approximate size** text field, type **15**.

3. Click **Continue** to exit the **Create Part** dialog box.

ABAQUS/CAE displays text in the prompt area near the bottom of the window to guide you through the procedure, as shown in Figure 11.3. Click the cancel button to cancel the current task; click the backup button to cancel the current step in the task and return to the previous step.

The Sketcher toolbox appears in the left side of the main window, and the Sketcher grid appears in the viewport.

You will first sketch an approximation of the plate and then use constraints and dimensions to refine the sketch. To select the appropriate drawing tool, do the following:

a. Click the **Create Lines: Rectangle** tool in the upper-right region of the Sketcher toolbox, as shown in Figure 11.4.

The rectangle drawing tool appears in the Sketcher toolbox with a white background, indicating that you selected it. ABAQUS/CAE displays prompts in the prompt area to guide you through the procedure.

Notice that as you move the cursor around the viewport, ABAQUS/CAE displays the cursor’s $X$- and $Y$-coordinates in the upper-left corner.

b. Select any two points as the opposite corners of the rectangle.

c. Use the dimension tool to dimension the top and left edges of the rectangle. The top edge should have a horizontal dimension of 2 m, and the left edge should have a vertical dimension of 1 m. When dimensioning each edge, simply select the line, click mouse button 1 to position the dimension text and then enter the new dimension in the prompt area.

d. Use the **Delete** tool to delete the perpendicular constraints associated with the bottom edge of the rectangle (select **Constraints as the Scope** in the prompt area to facilitate your selections).

e. Dimension the right edge of the plate so that it has a vertical dimension of 0.5 m. The final sketch appears as shown in Figure 11.5.

f. Click mouse button 2 anywhere in the viewport to finish using the dimension tool. (Mouse button 2 is the middle mouse button on a three-button mouse; on a two-button mouse, press both mouse buttons simultaneously.)

g. Click **Done** in the prompt area to exit the sketcher.
ABAQUS/CAE displays the new part, as shown in Figure 11.6.

### 11.4 CREATING A MATERIAL DEFINITION

You will now create a single linear material with a conductivity of 5 units.

**To define a material:**

1. In the Model Tree, double-click **Materials** to create a new material.
2. In the **Edit Material** dialog box, name the material **example**. Notice the various options available in this dialog box.
3. From the material editor's menu bar, select **Thermal → Conductivity**, as shown in Figure 11.7.
4. Enter a value of 5.0 for the conductivity, as shown in Figure 11.8. Use the mouse to select a cell for data entry.
5. Click OK to exit the material editor.

11.5 DEFINING AND ASSIGNING SECTION PROPERTIES

Material properties are associated with part regions through the use of section properties. You will define a solid section property that refers to the material created above and assign this section property to the part.

To define a homogeneous solid section:

1. In the Model Tree, double-click Sections to create a new section.
2. In the Create Section dialog box:
   a. Name the section plateSection.
   b. In the Category list, accept Solid as the default category selection.
   c. In the Type list, accept Homogeneous as the default type selection.
   d. Click Continue.

The solid section editor appears.
3. In the Edit Section dialog box:
   a. Accept the default selection of example for the Material associated with the section.
   b. Accept the default value of 1 for Plane stress/strain thickness.
   c. Click OK.

To assign the section definition to the plate:

1. In the Model Tree, expand the branch for the part named plate (click the '+' symbol to expand the Parts container and then click the '+' symbol next to the part named plate).
2. Double-click Section Assignments to assign a section to the plate.
   ABAQUS/CAE displays prompts in the prompt area to guide you through the procedure.
3. Click anywhere on the plate to select the entire part.
   ABAQUS/CAE highlights the plate.
4. Click mouse button 2 in the viewport or click Done in the prompt area to accept the selected geometry. The Edit Section Assignment dialog box appears containing a list of existing section definitions.
5. Accept the default selection of plate Section, and click OK.

ABAQUS/CAE assigns the solid section definition to the plate and closes the Edit Section Assignment dialog box.
11.6 ASSEMBLING THE MODEL

Every ABAQUS model is based on the concept of an assembly of part instances. You will create an assembly containing a single instance of the part created earlier.

To assemble the model:

1. In the Model Tree, expand the branch for the Assembly container and double-click Instances to create a new part instance.
2. In the Create Instance dialog box, select plate and click OK.

11.7 CONFIGURING THE ANALYSIS

To simulate the thermal response of the plate, a single heat transfer step will be used.

To create a heat transfer analysis step:

1. In the Model Tree, double-click Steps to create a step.
2. From the list of available general procedures in the Create Step dialog box, select Heat transfer and click Continue.
   The Edit Step dialog box appears.
3. In the Description field of the Basic tabbed page, enter Two-dimensional steady-state heat transfer.
4. Change the response type to Steady-state.
5. Accept all other default values provided for the step.
6. Click OK to create the step and to exit the step editor.

11.8 APPLYING A BOUNDARY CONDITION AND A LOAD TO THE MODEL

The loads and boundary conditions applied to the model are depicted in Figure 11.1. The temperature $T = 0$ is prescribed along the edges AB and AD. The heat fluxes $\dot{q} = 0$ and $\dot{q} = 20$ are prescribed on the edges BC and CD, respectively. A constant heat source $Q = 6$ is applied over the entire plate.

When assigning these attributes, you have the choice of selecting regions directly in the viewport or assigning them to predefined sets and surfaces. In this example, we adopt the latter approach. Thus, you will first define sets and surfaces.

To define sets and surfaces:

1. In the Model Tree, double-click Sets (underneath the Assembly) to create a new set. In the Create Set dialog box, name the set left and click Continue. Select the left vertical edge of the plate and click Done in the prompt area.
2. Similarly, create the following sets:
   - bottom at the bottom (skewed) edge of the plate;
   - plate for the entire plate.
3. In the Model Tree, double-click Surfaces (underneath the Assembly) to create a new surface. In the Create Surface dialog box, name the surface top and click Continue. Select the top horizontal edge of the plate and click Done in the prompt area.
To apply boundary conditions to the plate:

1. In the Model Tree, double-click BCs to create a new boundary condition.
2. In the Create Boundary Condition dialog box:
   - Name the boundary condition **left temp**.
   - Select Step-1 as the step in which the boundary condition will be activated.
   - In the Category list, select Other.
   - In the Types for Selected Step list, select Temperature and click Continue.
3. In the prompt area, click Sets to open the Region Selection dialog box. Select the set **left** and toggle on Highlight selections in viewport. The highlighted edge appears as shown in Figure 11.9.
4. When you are satisfied that the correct set has been selected, click Continue. The Edit Boundary Condition dialog box appears.
5. In the Edit Boundary Condition dialog box, enter a magnitude of 0.
6. Accept the default Amplitude selection (Ramp) and the default Distribution (Uniform).
7. Click OK to create the boundary condition and exit the editor. ABAQUS/CAE displays yellow squares along the edge to indicate a temperature boundary condition has been prescribed.
8. Repeat the above steps to assign the boundary condition to the bottom edge. Name this boundary condition **bottom temp**.

To apply a surface flux to the top edge of the plate:

1. In the Model Tree, double-click Loads to create a new load.
2. In the Create Load dialog box:
   - Name the load **surface flux**.
   - Select Step-1 as the step in which the load will be applied.
   - In the Category list, select Thermal.
   - In the Types for Selected Step list, select Surface heat flux.
   - Click Continue.
3. In the Region Selection dialog box, select the surface named **top**. The surface appears as shown in Figure 11.10.
4. When you are satisfied that the correct surface has been selected, click Continue. The Edit Load dialog box appears.
5. In the Edit Load dialog box:
   - Enter a magnitude of 20 for the load.
   - Accept the default Amplitude selection (Ramp) and the default Distribution (Uniform).
   - Click OK to create the load definition and to exit the editor.

   ABAQUS/CAE displays green downward-pointing arrows along the top face of the plate to indicate an inward flux.

To apply a body flux to the plate:

1. In the Model Tree, double-click Loads to create a new load.
2. In the Create Load dialog box
   - Name the load Body flux.
   - Select Step-1 as the step in which the load will be applied.
   - In the Category list, select Thermal.
   - In the Types for Selected Step list, select Body heat flux.
   - Click Continue.
3. In the Region Selection dialog box, select the set named plate and click Continue.
4. In the Edit Load dialog box:
   - Enter a magnitude of 6 for the load.
   - Accept the default Amplitude selection (Ramp) and the default Distribution (Uniform).
   - Click OK to create the load definition and to exit the editor.

   ABAQUS/CAE displays yellow squares along the remaining edges of the plate.

   The right edge of the plate is fully insulated. This is the default boundary condition for a thermal analysis model. Thus, you need not apply a boundary condition or load to this edge.

### 11.9 MESHING THE MODEL

You use the Mesh module to generate the finite element mesh. You can choose the meshing technique that ABAQUS/CAE will use to create the mesh, the element shape and the element type. ABAQUS/CAE offers a number of different meshing techniques. The default meshing technique assigned to the model is indicated by the color of the model when you enter the Mesh module; if ABAQUS/CAE displays the model in orange, it cannot be meshed without assistance from the user.
To assign the mesh controls:

1. In the Model Tree, double-click Mesh in the branch for the part named plate.
2. From the main menu bar of the Mesh module, select Mesh → Controls.
3. In the Mesh Controls dialog box, choose Tri as the Element Shape selection.
4. Accept Free as the default Technique selection.
5. Click OK to assign the mesh controls and to close the dialog box.

To assign an abaqus element type:

1. From the main menu bar, select Mesh → Element Type.
2. In the Element Type dialog box, choose the following:
   - Standard as the Element Library selection.
   - Linear as the Geometric Order.
   - Heat Transfer as the Family of elements.
3. In the lower portion of the dialog box, examine the element shape options. A brief description of the default element selection is available at the bottom of each tabbed page.
4. Click OK to assign DC2D3 elements to the part and to close the dialog box.

To mesh the part:

1. From the main menu bar, select Seed → Part to seed the part.
   The Global Seeds dialog box displays the default element size that ABAQUS/CAE will use to seed the part. This default element size is based on the size of the part.
2. Enter an approximate global size of 2.0 and click OK. This element size is chosen so that only one element will be created along each edge of the plate.
3. ABAQUS/CAE applies the seeds to the part, as shown in Figure 11.11. The squares in the figure indicate fixed node locations.
4. From the main menu bar, select Mesh → Part to mesh the part.
5. Click Yes in the prompt area or click mouse button 2 in the viewport to confirm that you want to mesh the part.
6. ABAQUS/CAE meshes the part and displays the resulting mesh, as shown in Figure 11.12a.
7. If you wish to change the diagonal of the elements, select Mesh → Edit. In the Edit Mesh dialog box, select Element as the category and Swap diagonal as the method. Click OK. In the viewport, select the shared diagonal edge of the elements. Click Yes in the prompt area to complete the operation. The mesh appears as shown in Figure 11.12b.

![Figure 11.11 Seeded part instance.](image-url)
11.10 CREATING AND SUBMITTING AN ANALYSIS JOB

You will now create a job and submit it for analysis.

To create and submit an analysis job:

1. In the Model Tree, double-click Jobs to create a new analysis job.
2. Name the job tri-coarse.
3. From the list of available models select heat.
4. Click Continue to create the job.
5. In the Description field of the Edit Job dialog box, enter Coarse triangle mesh.
6. Click the tabs to see the contents of each folder of the job editor and to review the default settings. Click OK to accept the default job settings.
7. In the Model Tree, expand the Jobs container and click MB3 on the job named tri-coarse. In the menu that appears, select Submit to submit your job for analysis. The icon for the job will change to indicate the status of the job in parenthesis after the job name. As the job runs, the status Running will be shown in the Model Tree.
8. When the job completes successfully, the status field will change to Completed. You are now ready to view the results of the analysis in the Visualization module.

11.11 VIEWING THE ANALYSIS RESULTS

1. In the Model Tree, click MB3 on the job tri-coarse and select Results from the menu that appears. ABAQUS/CAE opens the output database created by the job (tri-coarse.odb) and displays the undeformed model shape. You will create a contour plot of the temperature distribution.
2. From the main menu bar, select Result → Field Output and select NT11 as the output variable to be displayed.
3. In the Select Plot State dialog box, select As is and click OK.
4. In the toolbox, click the Plot Contours tool to view a contour plot of the temperature distribution, as shown in Figure 11.13.

11.12 SOLVING THE PROBLEM USING QUADRILATERALS

You will now solve the problem using quadrilateral elements. This involves changing the element shape and creating and submitting a new job. The steps are outlined below.
To modify a model:

1. In the Model Tree, double-click **Mesh** in the branch for the part named **plate** to switch to the Mesh module.
2. From the main menu bar of the Mesh module, select **Mesh → Controls**. Select **Quad** as the element shape and click **OK**.
3. A warning is issued indicating that the current mesh will be deleted. Click **Delete Meshes** in the ABAQUS dialog box to proceed.
4. From the main menu bar, select **Mesh → Part** to mesh the part with DC2D4 elements.
5. Click **Yes** in the prompt area or click mouse button 2 in the viewport to confirm that you want to mesh the part.
6. Create a new job. Name this job **quad-coarse** and give it the following description: **Coarse quad mesh**.
7. Submit the job for analysis and monitor its progress. When the job completes, open the file **quad-coarse.odb** in the Visualization module.
8. Plot the temperature contours for this model. The result is shown in Figure 11.14.

11.13 REFINING THE MESH

Clearly the mesh used to solve this problem was too coarse. For each choice of element shape (triangles and quadrilaterals), change the mesh seed size to refine the mesh. Use the following mesh seed sizes:

- **0.20** (this produces a finer mesh than used previously)
- **0.05** (this produces the finest mesh used in this study)

Thus, you will create and run four additional jobs named:

- tri-finer
- tri-finest
- quad-finer
- quad-finest
For each case, edit the model to redefine the mesh, create a new job, and submit it for analysis. Repeat this process until all jobs listed above have been submitted.

The results of the refined mesh models are shown in Figure 11.15.

From the main menu bar, select **File → Save** to save your model database file.